Come eravamo per capire chi siamo. Restauro, riparazione di strumenti vintage e apparecchiature di altri tempi.
#11117
Eccomi qui, questo è il quesito di cui parlavo o meglio a cui accennavo nelle presentazioni.
Possiedo un sintetizzatore Roland, un modello degli anni 90, per la precisione un W30 (il quale contempla una scheda di alimentazione identica ad altri modelli, dei quali però, oltre al W30, sono si riuscito a trovare il manuale di servizio, ma oltre al modello (anche se è già qualcosa) del trasformatore che dovrei sostituire, non c'è alcun cenno allo schema elettrico della scheda in questione.
In pratica, dopo aver acquistato la tastiera come funzionante, dopo non molto ho subito constatato che aveva dei problemi (che pensavo fossero dovuti ad un malfunzionamento del circutio legato al display, perché quest'ultimo si spegnava improvvisamente dopo un certo numero di secondi).
Cercando di riassumere tutto in poche righe (cosa non facile), ho trovato una pista interrotta sulla scheda madre (riparata mediante un ponticello: ho preferito fare in questa maniera anziché eseguire un lavoro meno appariscente), ho poi sostituito un transistor che avevo appurato avere un piedino spezzato, ho verificato la funzionalità di resistori e condensatori in zone strategiche (come ad esempio nel punto della scheda madre dove è situato il potenziometro per la regolazione del contrasto: potenziometro che avevo sostituito con uno di uguale resistenza, 10k e che alla seconda prova, sembrava essere stato il responsabile dello spegnimento del display (ma non poteva essere questo il motivo, infatti mi sembrava assurdo). Per proseguire, ho verificato il voltaggio proveniente dalla scheda di alimentazione e tutti i voltaggi sembravano essere corretti.
Un paio di giorni fa ho nuovamente acceso la tastiera (c'è da dire che lasciandola spenta per qualche minuto, nel momento in cui la accendevo nuovamente, il display visualizzava la scritta "Roland W30", ma senza che si avviasse il sistema operativo, sistema che comunque necessita di un dischetto di avvio o del sistema caricato su un hard disk, però per fare ciò dovrebbe apparire la scritta in cui viene richiesto di inserire il dischetto contenente il sistema operativo, cosa che non avveniva, tranne le prime due volte che l'ho accesa dopo averla acquistata e non ho proseguito perché, appunto, il dischetto fornito dal venditore era danneggiato) e dopo qualche secondo ho sentito il tipico rumore emesso da un componente mentre sta "friggendo" e orode di bruciato, ho subito disattivato l'alimentazione e staccato la spina, ho controllato quale componente avesse dei problemi e si sentiva chiaramente che l'odore proveniva dal trasformatore.
In seguito l'ho dissaldato e ho cercato le specifiche tecniche, ma nonostante diverse ricerche non le ho trovate (come ho già precisato, neanche mediante i manuali di servizio dei diversi modelli di campionatori che montano questa scheda di alimentazione). Poi cercando qui a casa ho trovato un trasformatore identico per dimensioni e pin sul primario e sul secondario.
Facendo un controllo (verificabile tramite le foto che allego) ho però constatato che alcuni pin sul secondario dei trasformatori sono collegati diversamente, ma ho pensato che per mezzo della costruzione di una piccola struttura realizzata con due strati di millefori separati da alcuni mm, potrei "deviare" i pin sul secondario del trasformatore recuperato (non quello originale) e predisporre i pin sulla seconda piazzola realizzata con la millefori, per poter fissare e saldare il trasformatore sulla scheda di alimentazione. Per appurare il rapporto tra il numero di spire presenti sul primario e sul secondario, senza collegare entrambe i trasformatori alla 220, ho pensato (dovrei averne uno) di collegare il primario di entrambi (cercando di verificare prima quali pin collegare al positivo e al negativo) i trasformatori ad un alimentatore Ac-Ac che eroghi un massimo di 15/18 volt, poi a seconda del risultato ottenuto sul secondario di entrambi, calcolare il numero di spire e verificare se siano uguali o in numero differente sui due trasformatori. Inoltre, per capire esattamente quanti volt siano disponibili in output sul secondario del trasformatore recuperato, sarebbe poi sufficiente moltiplicare i risultati per la differenza che intercorre tra i 15/18 volt inviati sul primario di entrambi i trasformatori e la 220 che abbiamo in casa, per cui moltiplicando all'incirca per 14,66/12,22 volte.
Secondo voi, sarebbe possibile un intervento del genere?
Purtroppo non riesco (e sono uno che cerca senza sosta) a trovare i dati tecnici di entrambe i trasformatori.
Una precisazione (per questo sto "modificando" il testo del post): il pin 2 del primario del trasformatore recuperato l'ho scollegato di proposito, perché dovrò posizionare il piedino presente sul primo pin, sul secondo.

Ecco le foto:
https://www.dropbox.com/sh/zcd1q96xg6mpa55/AADtontTl6PVkXPpuQRrhKl6a?dl=0
Grazie
#11120
C'è poco da dire
a) la descrizione dei guasti e degli interventi è molto confusa e non si capisce quasi nulla
b) I trasformatori, dall'esterno, sono più o meno tutti uguali, senza uno schema del circuito non si può sapere quanto valeva la tensione di uscita dell'originale. Quello che hai in casa, se buono, lo puoi provare e determinare il ropporto spire (non il numero di spire), se però l'originale è guasto e non si può provare te ne fai benpoco.
c) il link non porta a nulla
#11125
Ha ragione, a volte mi capita di commettere degli errori nella scrittura di un testo e per cercare di riassumere, scrivere in maniera un po' caotica.

Quelli che seguono sono i passaggi che ho eseguito cronologicamente:

- Accendo la tastiera, ma per via delle condizioni disastrose del dischetto di avvio (del sistema operativo) non posso appurare se il campionatore (il W30 è una workstation che permette anche di campionare) funzioni correttamente o meno (il display mostra comunque la tipica scritta con la quale richiede l'inserimento del dischetto di sistema).
- Provando a regolare il contrasto del display, noto che il potenziometro non può essere ruotato fluidamente e oltretutto bisogna tenerlo premuto verso l'interno della tastiera, per cui lo dissaldo e ne provo uno con identiche caratteristiche (10k), fin qui tutto a posto.
- Alla successiva accensione accade qualcosa, durante una prova, ruotando al massimo il potenziometro, il display si spegne improvvisamente, ma spegnendo ed accendendo nuovamente la tastiera il display mostra nuovamente la scritta "Roland W30", solo che subentra un problema che prima non si era verificato: in pratica l'intensità del contrasto tende a variare autonomamente, senza che io stesso metta mano al potenziometro, ed il finale è sempre lo stesso, ossia il display si spegne da solo dopo circa 30/40 secondi, ma a volte sono necessari più secondi.
- Preciso che la scritta" Roland W30" rimane fissa, non compare più quella che mostra chiaramente la richiesta del dischetto di avvio.
- Verifico, dissaldandoli, alcuni componenti che interessano la parte circuitale che regola il contrasto del display: funzionano tutti correttamente, si tratta di un paio di resistori e un condensatore.
- Successivamente, visionando la scheda madre, noto 2 particolari: il primo riguarda una pista interrotta, pista che parte da un determinato punto e conduce proprio ad uno dei pin della cpu sulla scheda madre. Provvedo alla risoluzione del problema ponendo semplicemente un ponticello per mezzo di un piccolo filo. L'altro particolare riguarda un transistor adiacente la cpu, avente il piedino centrale spezzato poco prima del corpo di quest'ultimo: non si trattava semplicemente di uno di quei casi in cui un transisto viene posizionato su una zona della scheda elettronica e uno dei piedini viene tagliato appositamente, ma avendo visto che il piedino centrale era saldato, ho pensato quindi di acquistarne uno con le stesse specifiche tecniche e sostituire quello che c'era in origine: si trattava del transistor PST518A, sostituito con il PST518B (dopo aver letto il datasheet e aver visto che le specifiche sono praticamente le stesse). Il problema relativo al display e al suo spegnimento è però rimasto tale.
- Accendo (se così posso dire) per l'ultima volta la tastiera un paio di giorni fa e quasi immediatamente sento il tipico rumore emesso da un compomente che sta "friggendo" e un odore di bruciato: essendo però completamente disassemblata, la tastiera era aperte, per cui ho potuto girarla immediatamente e constatare che l'odore di bruciato proveniva proprio dal trasformatore in questione. Gli altri componenti sembra (dico sembra, non ho alcuna certezza in merito) non abbiano subito danni, ma dovrei controllarne alcuni. Per il momento posso dire che ad esempio il fusibile è perfettamente funzionante.
2 - Si, avevo pensato a questo, facendo un test al volo con entrambi i trasformatori, sembra che quello originale non dia segni di vita, per cui potrebbe essere impossibile risalire ad alcuni dati.
3 - Il link che ho allegato l'ho verificato prima di pubblicare il messaggio, provandolo diverse volte vedo che funziona regolarmente, non so per quale motivo a lei non restituisce nulla.

Mi scuso se anche in questo caso possa aver commesso alcuni errori di digitazione, sono parecchio stressato e qualcosa potrebbe "sfuggirmi" o comunque potrei fare confusione.
Grazie
#11126
Se può servire qui il Service Manual del W30: https://manuals.fdiskc.com/flat/Roland%20W-30%20Service%20Manual.pdf

A pag. 9 si deduce che le alimentazioni fornite sono +5V, +15V e -15V


Da quello che dicono qui sembra che lo schema dell’alimentatore TDK sia assente dai vari Service Manual, e che esista solo una versione parziale sul Service Manual dello S-770 a pagina 20, dal quale almeno si possono vedere le tensioni presenti sul connettore e le relative posizioni.

Alle brutte forse conviene realizzare un alimentatore da zero con un PCB meccanicamente compatibile (ovviamente sapendolo fare).

EDIT: però riguardando meglio lo schema a pag.20 non vedo l'uscita a -15V. Mah...
#11127
Just4Fun ha scritto:Se può servire qui il Service Manual del W30: https://manuals.fdiskc.com/flat/Roland%20W-30%20Service%20Manual.pdf

A pag. 9 si deduce che le alimentazioni fornite sono +5V, +15V e -15V


Da quello che dicono qui sembra che lo schema dell’alimentatore TDK sia assente dai vari Service Manual, e che esista solo una versione parziale sul Service Manual dello S-770 a pagina 20, dal quale almeno si possono vedere le tensioni presenti sul connettore e le relative posizioni.

Alle brutte forse conviene realizzare un alimentatore da zero con un PCB meccanicamente compatibile (ovviamente sapendolo fare).

EDIT: però riguardando meglio lo schema a pag.20 non vedo l'uscita a -15V. Mah...


Si, avevo già visionato diversi service manual (come ha evidenziato, altri modelli fanno uso di quella scheda di alimentazione), ma se nella descrizione dei passaggi effettuati (dimentico sempre almeno una cosa o un passaggio) ho dimenticato di scrivere che avevo anche controllato i voltaggi in uscita dalla stessa scheda ed erano corretti, rimane il fatto che non essendoci purtroppo una descrizione dettagliata della circuitazione della scheda di alimentazione, è un problema in più.
#11129
Se il necessario è un "piccolo" alimentat0re con uscita in DC +5 +15 -15 non vedo il problema. La possibilità di trovare un trasformatore con caratteristiche identiche all'originale, a meno che non lo abbia il servizio assistenza, la vedo difficile.
#11130
schottky ha scritto:Se il necessario è un "piccolo" alimentat0re con uscita in DC +5 +15 -15 non vedo il problema. La possibilità di trovare un trasformatore con caratteristiche identiche all'originale, a meno che non lo abbia il servizio assistenza, la vedo difficile.


Ecco un paio di screenshot relativi uno al blocco diagrammi, l'altro alla pcb della scheda madre.

Roland W30_Diagramma 1.PNG
Allegati
Roland W30_Voltaggi provenienti dalla scheda di alimentazione.PNG
Altoparlanti a vibrazione

Di contro questi oggetti a vibrazione mi fanno tem[…]

Mancanza di libertà di parola

..speriamo che ascoltino la musica!

nessuno che può aiutarmi a preassemblare le compon[…]

Ascoltare anche gli infrasuoni..

Come sensore per rice-trasmettere infrasuoni ho vi[…]

Visita il nostro canale telegram